CCSNH IT Outage: Barracuda incident affecting delay in incoming emails to CCSNH

Incident Report for CCSNH

Resolved

Barracuda Networks has resolved the issue. External emails are beginning to come in. Please allow some time for all of them to come through. Thank you for your patience.

If you have any questions, please email CentralITHelpDesk@ccsnh.edu.
Posted Jul 16, 2025 - 10:27 EDT

Investigating

Barracuda Networks is currently investigating an issue on their end which is causing a delay in external emails coming into CCSNH. Internal emails are not affected by this. We are following this and will provide updates as we have them available. We apologize for any inconvenience.

Please visit http://status.ccsnh.edu for more information about services affected. If you have any questions, please email CentralITHelpDesk@ccsnh.edu.

Thank you,
CCSNH IT Support
Posted Jul 16, 2025 - 09:48 EDT
This incident affected: Barracuda Services.