CCSNH IT Outage: CCSNH Help Desk Emails/Notifications

Incident Report for CCSNH

Resolved

To all CCSNH Faculty, Staff and Students,

This issue has been resolved. Thank you for your patience.

Thank you,
CCSNH IT Support
.......................................................................

We are currently experiencing an issue with the emails and notifications to and from our internal help desk. Email, chat and phone options are still available with our external help desk at https://resources.ccsnh.edu.

We are investigating this issue and will send updates as we have them. We apologize for any inconvenience.

Please visit https://resources.ccsnh.edu to submit a ticket by email, chat or phone to the 24/7 personal support center.

Thank you,
CCSNH IT Support
Posted Apr 21, 2026 - 16:30 EDT

Identified

To all CCSNH Faculty, Staff and Students,

We are currently experiencing an issue with the emails and notifications to and from our internal help desk. Email, chat and phone options are still available with our external help desk at https://resources.ccsnh.edu.

We are investigating this issue and will send updates as we have them. We apologize for any inconvenience.

Please visit https://resources.ccsnh.edu to submit a ticket by email, chat or phone to the 24/7 personal support center.

Thank you,
CCSNH IT Support
Posted Apr 21, 2026 - 15:41 EDT
This incident affected: CCSNH Help Desk.