To all CCSNH Faculty, Staff and Students: Microsoft is reporting all services are operational this morning. If you're still experiencing issues, please visit https://resources.ccsnh.edu to submit a ticket. Thank you, CCSNH IT Support
Posted Jul 24, 2026 - 07:36 EDT
Update
Current status: Microsoft reports the impact is resolved for the vast majority of users. They're reviewing all known impact scenarios and monitoring for a period of time to confirm resolution for all affected environments.
Posted Jul 23, 2026 - 15:29 EDT
Monitoring
We are continuing to monitor Microsoft status.
Posted Jul 23, 2026 - 13:03 EDT
Update
Microsoft is continuing to work on a fix for this issue.
Posted Jul 23, 2026 - 13:03 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 23, 2026 - 11:58 EDT
Investigating
To all CCSNH Faculty, Staff and Students:
Microsoft is currently experiencing issues which is causing a partial outage for many CCSNH users. Some areas affected are Teams, OneDrive and Sharepoint. We are following the reports from Microsoft and will send updates as we have them available. We apologize for the inconvenience.